New OCNA website: Known issues

About the Opencaching Site
Bon Echo
Site Admin
Posts: 296
Joined: Mon Feb 11, 2013 7:39 pm

New OCNA website: Known issues

Post by Bon Echo » Mon Jul 01, 2019 2:06 pm

In late June 2019 OCNA upgraded (from a very old, circa 2010 version of the opencaching.pl code) to a new feature-rich version of the opencaching.pl code. There were (and still are) a number of challenges to bring all unique OCNA features on board with the new code. We have been hard at work to resolve all those issues and had planned to solve all (or at least most) before the site migration, but an unplanned server upgrade left us with little choice but to move ahead with the new site with all it's imperfections. Over the coming weeks and months we will try to fix as many of these as we can. Please post here if you see other issues that need attention

MAJOR issues
:
- certain cache types do not function / display properly or at all
----- cannot search for (BIT, Guestbook, Letterbox)
----- moving caches are displayed as being type "Podcache"
----- cannot change cache type to Own Cache
- emails are being blocked by some email providers (AT&T)
- cannot Hide a Cache (region information missing) [update 06/07 - regions for Canada and Mexico available on the Hide a cache page]
- cannot search by zip code or by state
- site not encrypted [fixed 06/07]

Smaller issues:
- search by cache type does not work (all cache types returned regardless of what is selected)
- challenge caches
- default search by coordinates is "N/E" instead of "N/W"
- only Canada, Mexico and USA listed in Countries list (other countries can be selected by first choose "Show All Countries")
- email notifications are not being delivered (cache owners are not notified when their cache has been logged)
- wiki needs updating to reflect new features (geopaths, guides)
- French and Spanish translations needed
- events not included in find count
- some attributes missing?
- "Because this is one of your first three caches, the listing will be available to others after being approved by the OC Team" incorrectly displayed on the Hide a Cache page
- cache adoption no working (there is a banner at the top of the page that indicates "You are not allowed to adopt caches")
- page error encountered when trying to view the New Caches page https://www.opencaching.us/newcaches.php
- option to allow the OC Team to "Publish cache upon acceptance" missing

Considering what was broken before the migration (could not view caches, most cache searches broken, could not view search results beyond one page), this is still a huge step forward. We (the OCNA admin team) are extremely grateful to andrixnet (opencaching.ro), harrieklomp (opencaching.nl) and other OC developers for the many hours they have contributed towards this upgrade
Last edited by Bon Echo on Sun Jul 21, 2019 9:57 pm, edited 9 times in total.

PTMY
Posts: 7
Joined: Wed Nov 07, 2018 9:02 pm

Re: New OCNA website: Known issues

Post by PTMY » Tue Jul 02, 2019 6:03 am

Yahoo emails went to spam.

Minor, but made Save hang: When editing/archiving Xlisted hide, it was shown as also xlisted at gpsgames, with error "Invalid GE waypoint". It was only xlisted at GC before. Erasing the GC code from gpsgames box was workaround.

PTMY
Posts: 7
Joined: Wed Nov 07, 2018 9:02 pm

Re: New OCNA website: Known issues

Post by PTMY » Tue Jul 02, 2019 6:27 am

Major: cgeo won't login (or do anything else).

More strict web browsers are unhappy with site certificate and ask for security exceptions. When doing that, a login screen appears for "DEV andrix.EU" so exception fails and site is unusable.

Less strict browser uses http connection, which is very 20th century and insecure for a "new improved" site.

Bon Echo
Site Admin
Posts: 296
Joined: Mon Feb 11, 2013 7:39 pm

Re: New OCNA website: Known issues

Post by Bon Echo » Sat Jul 06, 2019 8:18 am

BIG update last night - SSL encryption added. c:geo access restored

Mr.Yuck
Site Admin
Posts: 2137
Joined: Wed Aug 18, 2010 2:09 pm
Location: York County, Va.
Contact:

Re: New OCNA website: Known issues

Post by Mr.Yuck » Sat Jul 06, 2019 12:50 pm

It was actually more like 2008 PHP code. :D And for some reason, there are no official "versions" of the code. It's either the latest, or it isn't. When it's that old, and your hosting company keeps upgrading architecture, stuff just breaks. Just look at Navicache, which hasn't been tended to in 5 years or more. We were getting close to them, after our latest server upgrade.
ImageImage

Bon Echo
Site Admin
Posts: 296
Joined: Mon Feb 11, 2013 7:39 pm

Re: New OCNA website: Known issues

Post by Bon Echo » Mon Jul 08, 2019 7:46 am

PTMY wrote:
Tue Jul 02, 2019 6:03 am
Yahoo emails went to spam.

Minor, but made Save hang: When editing/archiving Xlisted hide, it was shown as also xlisted at gpsgames, with error "Invalid GE waypoint". It was only xlisted at GC before. Erasing the GC code from gpsgames box was workaround.
PTMY wrote:
Tue Jul 02, 2019 6:27 am
Major: cgeo won't login (or do anything else).

More strict web browsers are unhappy with site certificate and ask for security exceptions. When doing that, a login screen appears for "DEV andrix.EU" so exception fails and site is unusable.

Less strict browser uses http connection, which is very 20th century and insecure for a "new improved" site.

All of these appear to be fixed now (well, maybe not the yahoo email going to spam, I cannot test that from here)

harrieklomp
Posts: 3
Joined: Sat Oct 30, 2010 10:19 am

Re: New OCNA website: Known issues

Post by harrieklomp » Mon Jul 08, 2019 8:48 am

Bon Echo wrote:
Mon Jul 08, 2019 7:46 am

All of these appear to be fixed now (well, maybe not the yahoo email going to spam, I cannot test that from here)
The biggest problem is that new (configurated) sites have to prove they have good intentions when sending mail. OCNL had the same problem that email ended in spambox. The biggest problem where the Microsoft e-mail like outlook and hotmail accounts.
When e-mails ends in spamboxes Microsoft does see/register that. When this happens to often, than the sender (OCNA) goes to a blacklist. When a e-mail is in spambox the user should mark this as a save mail to build a positive reputation.

In other words, OCNA has to start all over to build a positive reputation when sending e-mails.

JASTA 11
Posts: 5
Joined: Thu Feb 24, 2011 7:27 pm

Re: New OCNA website: Known issues

Post by JASTA 11 » Fri Jul 12, 2019 11:34 am

I'm assuming that the forums are on a different server, since I'm able to post here.

You should let folks know that they have to reset our password to log on. Put up a banner or something.

I received your email blast on 6/25, but nothing since.

Is there a (mostly) functional website to use, or are there still major issues?

Bon Echo
Site Admin
Posts: 296
Joined: Mon Feb 11, 2013 7:39 pm

Re: New OCNA website: Known issues

Post by Bon Echo » Tue Jul 16, 2019 1:30 pm

JASTA 11 wrote:
Fri Jul 12, 2019 11:34 am
I'm assuming that the forums are on a different server, since I'm able to post here.

You should let folks know that they have to reset our password to log on. Put up a banner or something.

I received your email blast on 6/25, but nothing since.

Is there a (mostly) functional website to use, or are there still major issues?
There is a notice on the main page that says "Please note that we are currently experiencing issues with OCNA emails being blocked on some platforms. For example, emails sent to "@att.net" (AT&T) are not being received. We are working to resolve this issue. Unfortunately you will not be able to register or reset you password if you use AT&T or one of the other affected email platforms. If you use another email service and you are experiencing issues with OCNA emails please let us know: octeam@opencaching.us"

There is a great new site with so many fixes and upgrades vs the old site, but still a number of problems we are working to resolve. You can't access the new site? same address as before, https://www.opencaching.us

JASTA 11
Posts: 5
Joined: Thu Feb 24, 2011 7:27 pm

Re: New OCNA website: Known issues

Post by JASTA 11 » Wed Jul 17, 2019 1:26 pm

Banner doesn't explain that current members need to reset passwords to get into the upgraded site. It only mentions the att address issue. So I was wondering what is up.

Back in June you folks communicated about the issues with the upgrade. If things are up and running you should put that out too.

Post Reply